URGENT: RaceReplay camera initialization error!

Discussions on race preparation, race management, sound effects, and other race related software. This includes freeware, shareware and commercially available software.
User avatar
gpraceman
Site Admin
Site Admin
Posts: 4606
Joined: Fri Jun 20, 2003 12:46 am
Location: Highlands Ranch, CO
Contact:

Re: URGENT: RaceReplay camera initialization error!

Post by gpraceman » Fri Mar 21, 2014 7:43 pm

Unfortunately, I didn't see anything in the screenshots that might help. My only guess is that the camera is doing some hardware compression on the video stream. That will cause a problem with RR, as it needs an uncompressed stream.


Randy Lisano
Romans 5:8

Awana Grand Prix and Pinewood Derby racing - Where a child, an adult and a small block of wood combine for a lot of fun and memories.

User avatar
gpraceman
Site Admin
Site Admin
Posts: 4606
Joined: Fri Jun 20, 2003 12:46 am
Location: Highlands Ranch, CO
Contact:

Re: URGENT: RaceReplay camera initialization error!

Post by gpraceman » Fri Mar 21, 2014 7:45 pm

This seems to confirm that the C920 does hardware compression.

http://forums.logitech.com/t5/Webcams/w ... d-p/799631


Randy Lisano
Romans 5:8

Awana Grand Prix and Pinewood Derby racing - Where a child, an adult and a small block of wood combine for a lot of fun and memories.

kyoo
Journeyman
Journeyman
Posts: 30
Joined: Mon Jan 30, 2012 2:38 pm
Location: Austin, TX

Re: URGENT: RaceReplay camera initialization error!

Post by kyoo » Fri Mar 21, 2014 7:47 pm

Is that a new requirement since RR V2? Because I used this same camera last year..

The Logitech C920 does boast having H.264 compression.. I assume that must be in the hardware..

Should I try RR V2?



kyoo
Journeyman
Journeyman
Posts: 30
Joined: Mon Jan 30, 2012 2:38 pm
Location: Austin, TX

Re: URGENT: RaceReplay camera initialization error!

Post by kyoo » Fri Mar 21, 2014 7:48 pm

btw, I emailed you again w/ some logitech diagnostic output zips.. from an older camera the works and this one as well..



User avatar
gpraceman
Site Admin
Site Admin
Posts: 4606
Joined: Fri Jun 20, 2003 12:46 am
Location: Highlands Ranch, CO
Contact:

Re: URGENT: RaceReplay camera initialization error!

Post by gpraceman » Fri Mar 21, 2014 7:54 pm

kyoo wrote:Is that a new requirement since RR V2? Because I used this same camera last year..

The Logitech C920 does boast having H.264 compression.. I assume that must be in the hardware..

Should I try RR V2?
That has been a requirement for RR since V1. Yes, that camera is doing its own compression.

From the requirements listed on our website and when installing RR:
Does not perform any hardware video compression
I'm surprised that you were able to to get it working with V2. You can give it a try again and see if you can confirm that. There was only one small tweak to V3 in terms of the hardware interface.

Those logs are rather foreign. I'm not sure that I can glean anything from them.


Randy Lisano
Romans 5:8

Awana Grand Prix and Pinewood Derby racing - Where a child, an adult and a small block of wood combine for a lot of fun and memories.

kyoo
Journeyman
Journeyman
Posts: 30
Joined: Mon Jan 30, 2012 2:38 pm
Location: Austin, TX

Re: URGENT: RaceReplay camera initialization error!

Post by kyoo » Fri Mar 21, 2014 8:00 pm

Ok.. I installed the latest V2, and the video preview works w/ the C920..

Any chance you can tweak the V3 build for me right quick? ;)



User avatar
gpraceman
Site Admin
Site Admin
Posts: 4606
Joined: Fri Jun 20, 2003 12:46 am
Location: Highlands Ranch, CO
Contact:

Re: URGENT: RaceReplay camera initialization error!

Post by gpraceman » Fri Mar 21, 2014 8:12 pm

If it won't work with V3.0.916, then I don't know what could be the issue. That tweak was in the 1508 update.


Randy Lisano
Romans 5:8

Awana Grand Prix and Pinewood Derby racing - Where a child, an adult and a small block of wood combine for a lot of fun and memories.

kyoo
Journeyman
Journeyman
Posts: 30
Joined: Mon Jan 30, 2012 2:38 pm
Location: Austin, TX

Re: URGENT: RaceReplay camera initialization error!

Post by kyoo » Fri Mar 21, 2014 8:15 pm

I'll uninstall V3 (w/ updates) and reinstall the V3 (w/o updates) again and test again.. i noticed some windows\system32 dll had to be overwritten when installing V2 again..



kyoo
Journeyman
Journeyman
Posts: 30
Joined: Mon Jan 30, 2012 2:38 pm
Location: Austin, TX

Re: URGENT: RaceReplay camera initialization error!

Post by kyoo » Fri Mar 21, 2014 8:18 pm

oh.. apparently the initial installer is also 1508 now.. can you confirm the d/l link for 3.0.916?



kyoo
Journeyman
Journeyman
Posts: 30
Joined: Mon Jan 30, 2012 2:38 pm
Location: Austin, TX

Re: URGENT: RaceReplay camera initialization error!

Post by kyoo » Fri Mar 21, 2014 9:04 pm

Shucks.. did I lose you for the night?

Does anyone have a d/l link for RaceReplay v3.0.916?



kyoo
Journeyman
Journeyman
Posts: 30
Joined: Mon Jan 30, 2012 2:38 pm
Location: Austin, TX

Re: URGENT: RaceReplay camera initialization error!

Post by kyoo » Fri Mar 21, 2014 9:46 pm

btw, GRPM V13 image capture/preview functionality works file with the C920 camera..

I'm going to head to bed soon.. hopefully I can get my hands on 3.0.916 in the morning.. or a new build you might have available to try.. I start setting up about 10am Central tomorrow..



kyoo
Journeyman
Journeyman
Posts: 30
Joined: Mon Jan 30, 2012 2:38 pm
Location: Austin, TX

Re: URGENT: RaceReplay camera initialization error!

Post by kyoo » Fri Mar 21, 2014 10:23 pm

Randy, thanks for emailing me the 3.0.916 executable.. that one works for me! You're the best!

I'm happy to test builds to see if newer ones can load up the Logitech C920 or not.. I'll keep tabs on this thread..



User avatar
gpraceman
Site Admin
Site Admin
Posts: 4606
Joined: Fri Jun 20, 2003 12:46 am
Location: Highlands Ranch, CO
Contact:

Re: URGENT: RaceReplay camera initialization error!

Post by gpraceman » Tue Apr 22, 2014 11:50 am

For anyone checking out this thread, I did post an update to V3, last month, that resolved this issue.


Randy Lisano
Romans 5:8

Awana Grand Prix and Pinewood Derby racing - Where a child, an adult and a small block of wood combine for a lot of fun and memories.

User avatar
gpraceman
Site Admin
Site Admin
Posts: 4606
Joined: Fri Jun 20, 2003 12:46 am
Location: Highlands Ranch, CO
Contact:

Re: URGENT: RaceReplay camera initialization error!

Post by gpraceman » Mon Jul 14, 2014 1:06 pm

Josh,

I have another user running into problems with another Logitech webcam that has H.264 compression. He can preview but not record. The trick seems to be finding a video compressor that can decode a H.264 video stream. What specific video compressor were you using with RR?


Randy Lisano
Romans 5:8

Awana Grand Prix and Pinewood Derby racing - Where a child, an adult and a small block of wood combine for a lot of fun and memories.

User avatar
gpraceman
Site Admin
Site Admin
Posts: 4606
Joined: Fri Jun 20, 2003 12:46 am
Location: Highlands Ranch, CO
Contact:

Re: URGENT: RaceReplay camera initialization error!

Post by gpraceman » Mon Jul 14, 2014 2:52 pm

Never mind on that. I got a hold of a C920 and had no problems getting it to record using several different compressors, even no compressor. It seems that he has a Logitech driver issue.


Randy Lisano
Romans 5:8

Awana Grand Prix and Pinewood Derby racing - Where a child, an adult and a small block of wood combine for a lot of fun and memories.

Post Reply